Opel Zafira Problem z ECU

Czyli problemy z prądem w Opel Zafira (osprzęt elektryczny, włączniki, przekaźniki, szyby elektryczne, oświetlenie itp.)

Moderatorzy: Mariusz, Tazz

Wiadomość
Autor
materna11
Świeżak
Posty: 8
Rejestracja: 24 sty 2024, 10:08
Imię: Mateusz
Lokalizacja: Gdańsk
Auto: Zafira B 1.8 Benzyna LPG
Model: ZB
Oznaczenie silnika: Z18XER

Opel Zafira Problem z ECU

#1 Post autor: materna11 »

Witam. Problem, jak wielu, ale niestety żadna z opcji nie okazała się skuteczna. Mianowicie samochód po odpaleniu działa i po jakimś czasie włącza się ikonka ESP i check engine później wszystkie kontrolki znikająca moc i gaśnie.
Po wyłączeniu silnika przy próbie odpalenia zapalają się wszystkie kontrolki, brak możliwości odpalenia i brak komunikacji z ECU.

Nie da rady go włączyć przez jakiś czas po czym po jakimś czasie wszystko wraca do normy i tak w kółko.

Na pierwszy rzut poszedł Akumulator, bo i nie był zbyt młody. Kolejnym krokiem było sprawdzenie i wymiana kabli masowych sterownik, karoseria, silnik do akumulatora. Znacząco poprawiło to napięcie ładowania, dołożyłem również kabel plusowy do alternatora, ładowanie jeszcze wzrosło (okolice 14,5V spadek do 14,2 na niemal pełnym obciążeniu). Skrzynki bezpieczników czyste, żadnej korozji i wilgoci. Przy czym napięcie na ECU (aplikacja ScanMyOpel) pokazuje do 14,1 i niekiedy mniej, gdy w zapalniczce jest 14,5V i jedyny błąd jaki się pojawia to p0014, ale on jest cały czas, nawet gdy opisany problem nie występuje. (To zapewne koło zmiennych faz się kończy, bo zmiana zaworu nie pomogła). Napięcie na gnieździe OBD jak na akumulatorze. Czy ECU się zepsuło, czy jeszcze jakichś problemów we wiązce silnika szukać? Ewentualnie jaki kolejny krok?
Ostatnio zmieniony 09 lut 2024, 12:57 przez Pszczyna, łącznie zmieniany 1 raz.
Powód: Poprawiłem literówki

Awatar użytkownika
Pszczyna
Zafiromaniak
Posty: 1982
Rejestracja: 22 maja 2010, 17:57
Imię: Dariusz
Lokalizacja: Oberschlesien
Auto: Zafira B 1,9
Model: ZB
Oznaczenie silnika: Z19DT
Gender:

#2 Post autor: Pszczyna »

Nie jestem pewien czy 1.8 miały filtr węglowy par paliwa ale raczej nie ,wiem że mają je Astra J i K czy ZC (Silnik: 1.4-1.4T -1.6-1.6T) tu bym uderzył a zwłaszcza jego zawór

Z tym kodem P0014 były już odpowiedzi to szerokie spektrum tego zagadnienia.

Z do masowaniem to dodał bym silnik--karoseria.
Jeszcze bym sprawdził regulator alternatora -kwestia rozładowywania aku.

P0014 jest ogólnym kodem OBD-II, który wskazuje, że moduł sterowania silnikiem (ECM) ustalił, że wałek rozrządu wydechu w banku 1 jest bardziej wysunięty niż ECM nakazał mu być.
Ten stan nadmiernego wyprzedzenia może wystąpić podczas wyprzedzenia lub opóźnienia wałka rozrządu (położenia wałka rozrządu).

To problemy z układem wydechowym (Bank 1) sonda Lambda, warto przejrzeć cały wydech pod kontem szczenności.


Siłownikiem położenia wałka rozrządu.
Wałek rozrządu zaworów wydechowych przekroczył prędkość obrotową, gdy ECM nakazał wałkowi rozrządu cofnięcie się do niższego poziomu rozrządu.
Problemy:
,,Lampka kontrolna Check Engine zapala się, sygnalizując problem.
Jeśli wałek rozrządu jest wysunięty za bardzo do przodu, silnik może ciężko się uruchamiać.
Przebieg paliwa zostanie zmniejszony, ponieważ wałki rozrządu nie znajdują się w optymalnym położeniu dla uzyskania dobrego przebiegu paliwa.
W zależności od położenia wałka rozrządu silnik może nie zapalić lub zgaśnie.
Emisja spalin z silnika spowoduje, że pojazd nie przejdzie testów emisji spalin."

18 te silniki są czułe na jakość oraz odpowiedni poziom oleju.
Lepkość oleju jest zbyt duża, co powoduje zatykanie się kanałów, co powoduje ograniczenie przepływu oleju do i z fazowników wałka rozrządu.
Przesuwnik wałka rozrządu jest zablokowany w pozycji wysuniętej.
Cewka sterująca olejem wałka rozrządu na banku 1 może być zwarta w pozycji otwartej.

Zmiennymi fazami rozrządu lub elektromagnesem zaworu.

materna11
Świeżak
Posty: 8
Rejestracja: 24 sty 2024, 10:08
Imię: Mateusz
Lokalizacja: Gdańsk
Auto: Zafira B 1.8 Benzyna LPG
Model: ZB
Oznaczenie silnika: Z18XER

#3 Post autor: materna11 »

Co do p0014 jak wcześniej to badałem, to wiem, że bank 1 jest cały czas otwarty. Mówisz, że to może być wina oleju jaki jest w silniku? Płukanka i rzadszy olej może być rozwiązaniem? I jeden szczegół- może to być powodem lekkiego szarpania przy zimnym silniku ?

Druga sprawa to te wariacje i brak kontaktu z ECU. Masę do karoserii też dołożyłem, ale zauważyłem jeden szczegół- gdy aku jest słabsze owe wariacje występują szybciej. Możliwe jest że mimo braku widocznego na multimetrze nawet chwilowego spadku napięcia (cały czas powyżej 14V) regulator jest uszkodzony i to może być problemem?

Awatar użytkownika
Pszczyna
Zafiromaniak
Posty: 1982
Rejestracja: 22 maja 2010, 17:57
Imię: Dariusz
Lokalizacja: Oberschlesien
Auto: Zafira B 1,9
Model: ZB
Oznaczenie silnika: Z19DT
Gender:

#4 Post autor: Pszczyna »

Masz wszystko napisane ,zrób porządek z sondą oraz skoro jest LPG też warto się przyjrzeć jego sterownikowi.
Dalej resztę po kolei, ja tobie nie podam 100% serum, zważ iż tu tylko wymieniamy się doświadczeniami i poradami.
Co do oleju była szeroka dyskusja nad jakością stosowanego w 1,8 oraz jego poziomem (za niskim w stosunku co zalecał producent).

materna11
Świeżak
Posty: 8
Rejestracja: 24 sty 2024, 10:08
Imię: Mateusz
Lokalizacja: Gdańsk
Auto: Zafira B 1.8 Benzyna LPG
Model: ZB
Oznaczenie silnika: Z18XER

#5 Post autor: materna11 »

Dzisiaj podłączyłem OP Com'a i wyszła mi ładna lista błędów. w przyszłym tygodniu wymienię sondę lambda, a co do reszty, to będę musiał sprawdzić co oznaczają poszczególne błędy.
0140
0650
1613
0009
1614
0014
0415
0564
0121
Ewentualnie w jakiej kolejności szukać usterek.

Awatar użytkownika
Pszczyna
Zafiromaniak
Posty: 1982
Rejestracja: 22 maja 2010, 17:57
Imię: Dariusz
Lokalizacja: Oberschlesien
Auto: Zafira B 1,9
Model: ZB
Oznaczenie silnika: Z19DT
Gender:

#6 Post autor: Pszczyna »

Dlaczego nie podajesz oznaczalna literowego poprzedzającego kod :
Pierwsza literka (np.P lub B,C,U)
Systemy
B= nadwozie
C= podwozie
P= napęd
U= sieć

P0140 : Czujnik O2 (Bank 1, Czujnik 2) – brak aktywności.
P0650 : Awaria obwodu sterującego lampki kontrolnej awarii (MIL).
P1613 to oznacza, że sterownik silnika jest prawdopodobnie uszkodzony.
0009
Z dopiskiem ,,U" U0009 Magistrala danych sieci kontrolera (CAN): szybka magistrala (-) – zwarta do magistrali danych (+)
Brak zasilania lub uziemienia do modułu
Błędy programowania PCM lub sterownika
Niewłaściwie dokręcone kable lub złącza komputera.
Przerwa w obwodzie magistrali CAN
CANbus jest otwarty lub zwarty do masy.
Przecięte, spalone lub uszkodzone wiązki przewodów lub złącza
Przerywane lub słabe połączenia w złączach obwodu.

Z literą ,,P"' P0009 - „położenia silnika osiągi systemu (Bank 2)
Zużyte części rozrządu (łańcuchy, koła zębate, prowadnice).
Nieprawidłowo wyregulowany łańcuch rozrządu.
Problem z napinaczem łańcucha rozrządu.
Uszkodzony czujnik położenia wału korbowego lub wałka rozrządu.
Uszkodzony wał korbowy lub wałek rozrządu.
Przestarzałe oprogramowanie ECM, konieczność przeprogramowania modułu.
Wewnętrzne uszkodzenie ECM.
Uszkodzenie wiązki przewodów elektrycznych.

1616 występuje wraz 1614 - " słaby punkt oprogramowania modułu CIM " - tak opisuje to biuletyn techniczny Opla. Krótko mówiąc , należy przeprogramować moduł CIMa najnowszym oprogramowaniem ( dot. Astry H wyprodukowanych do 2008r) lub ewentualnie wymienić CIMa.

P0014 usterka związana z wałkiem rozrządu, który oznacza, że ​​pozycja wałka rozrządu na banku 1 (prawy lub tylny) jest ustawiona poza zakresem lub przekracza limit czasu

0415 Zawór sterujący „B” w układzie doprowadzania powietrza dodatkowego
B0415,”Kontrola przepływu powietrza #4 – odpowietrznik – usterka”

P0564 – usterka obwodu wielofunkcyjnego wejścia „A” tempomatu
Uszkodzony jest przełącznik tempomatu.
Problem z okablowaniem (pęknięcie, przetarcia itp.).
Wadliwe złącze (np. skorodowane styki).
Odłamki i zanieczyszczenia zakłócają mechanicznie działanie przełącznika tempomatu.
Czasami przyczyną jest uszkodzony moduł PCM

P0121
Obwód A czujnika TPS wyuczonego zakresu do ECM był większy niż określona różnica napięcia między obwodem B czujnika TPS o więcej niż 1,6 V.
Wyuczony zakres sygnału wyjściowego z obwodu A czujnika TPS do ECM był mniejszy niż określona różnica napięcia między obwodem B czujnika TPS a ECM o mniej niż 0,8 V.
oznaki--
ECM włącza kontrolkę Check Engine i przechodzi w tryb bezpieczeństwa, odcinając zasilanie siłownika przepustnicy, aby doprowadzić do otwarcia przepustnicy do około mniej niż 6 stopni.
ECM steruje wtryskiem paliwa i rozrządem w celu kontroli prędkości obrotowej silnika.
Pojazd może być prowadzony bardzo powoli z ograniczoną reakcją przepustnicy.
Silnik może pracować na wyższych obrotach jałowych niż normalnie i nie przyspieszać tak jak wcześniej.

materna11
Świeżak
Posty: 8
Rejestracja: 24 sty 2024, 10:08
Imię: Mateusz
Lokalizacja: Gdańsk
Auto: Zafira B 1.8 Benzyna LPG
Model: ZB
Oznaczenie silnika: Z18XER

#7 Post autor: materna11 »

Co do P1613, to uszkodzenie sterowników to raczej usterka softwarowa, czy raczej mechaniczna wewnątrz sterownika (zimne luty itp.)? Które z nich są częstsze? Sterownik prosty w budowie, bez żadnych drucików od wtyczek na nim.

materna11
Świeżak
Posty: 8
Rejestracja: 24 sty 2024, 10:08
Imię: Mateusz
Lokalizacja: Gdańsk
Auto: Zafira B 1.8 Benzyna LPG
Model: ZB
Oznaczenie silnika: Z18XER

#8 Post autor: materna11 »

Wolny weekend i końcu wróciłem do zabawy w oplu. Grzebałem trochę i zauważyłem jedną rzecz odnośnie pojawiania się tych błędów. Jak to jest z komunikacją w tym oplu?

Szeregowa tzn., że jest, i tracimy ją na pierwszym module z którym jest problem I urywa się kontakt z pozostałymi w szeregu za nim w sieci? Bo nie rozbierałem akurat wtyku od modułu ABS, a ESP i ABS to pierwsze kontrolki, które się pojawiają i po tym tracę kontakt ze wszystkim prócz ECU silnika w tym momencie.

Lekko ruszyłem wtyk od ABS, pod zbiornikiem płynu chłodniczego. Niestety nie mogłem teraz go wymontować, aby zajrzeć do tej wtyczki. Włączyłem silnik "jak jeszcze działało", to na każdym module odczytałem nieaktywne problemy z komunikacją, nic poza tym. Ale jak się zaczęła "Dyskoteka" straciłem kontakt ze wszystkim prócz ECU i ABS- na tym wracał aktywnie błąd C0241,
a na ECU aktywnie wraca U0415
Ostatnio zmieniony 02 mar 2024, 19:59 przez Pszczyna, łącznie zmieniany 1 raz.
Powód: Poprawiłem literówki

Awatar użytkownika
Pszczyna
Zafiromaniak
Posty: 1982
Rejestracja: 22 maja 2010, 17:57
Imię: Dariusz
Lokalizacja: Oberschlesien
Auto: Zafira B 1,9
Model: ZB
Oznaczenie silnika: Z19DT
Gender:

#9 Post autor: Pszczyna »

Niedawno jeden z forumowiczów toczył bój ze wspomaganiem, po wszelkich----- za i przeciw----- doszedł iż za zbiornikiem tuż przy płycie grodziowej odczepiła się wiązka z mocowania i doszło do przetarcia jej o silnik.

Między modułami jest szyna CAN zazwyczaj czarny kabel taki przynajmniej odchodzi z radia.

ODPOWIEDZ

Wróć do „Elektryka i elektronika”